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CLS - Repairing Crystal Reports

Views: 1177 Last Updated: 02/13/2023 03:00 pm 0 Rating/ Voters
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Symptom

Previewing any Tab other than the Image Tab in On-Screen Takeoff and/or generating Quick Bid Reports does not work.

Cause

On-Screen Takeoff and Quick Bid use Crystal Reports 9 and Crystal Decisions 2.0 toprint reports, tabs, lists, etc. (everything but the Image Tab in On-Screen Takeoff).

Sometimes, during installing upgrades, these installations get corrupt or stop working. Uninstalling and reinstalling the application does not fix this issue. You willneed to remove the installations of Crystal Reports and Crystal Decisions from thecomputer in order to get the application installers to reinstall and re-registerthese products.

Caution
You will be deleting Common Files in the Program Files (or Program Files (x86)) directories. Only a Windows Administrator will be able to perform this operation.

Resolution

To repair Crystal Reports and Crystal Decisions, perform the following steps:

  • Open the Control Panel (consult your Windows documentation for details)
  • Click Programs and Features
  • Uninstall On-Screen Takeoff and Quick Bid (this does not affect any information stored in the databases (conditions, takeoff, assemblies, etc).

Once uninstalled, 

  • Open Windows Explorer (substitute "C:\Program Files (x86)" for 64-bit systems) in the instructions below)
  • In Windows Explorer, browse to "C:\Program Files\Crystal Decisions" and delete the Report Designer Component directory
  • Next, still In Windows Explorer, browse to "C:\Program Files\Common Files\Crystal Decisions" and delete the "2.0" directory

Once these two folders are deleted, you will need to run the Windows Registry Editor

Warning
The following steps require you to modify the Windows registry and possibly systemfiles. Modifications to the Windows registry and/or system files, if not done correctly,can cause Windows to stop working. Please contact an IT Professional to assist youif you are unfamiliar with any of these processes or terms.

  • Click Start,
  • Type "regedit" in the Start/Search field,
  • Press the <Enter> key on the keyboard

Once the Registry Editor opens,

  • Browse to the following keys and delete them:

KEY_CURRENT_USER\Software\Crystal Decisions\9.0

HKEY_LOCAL_MACHINE\SOFTWARE\Crystal Decisions\9.0

  • Close the Registry Editor
  • Reinstall the applications, starting with Quick Bid

Crystal Reports and Crystal Decisions will be reinstalled during the installation process.



Product documentation (user guides) describes functionality in the latest version of each major release and may not match the functionality in the version you are using. Please check the Product Information and Downloads pages by clicking one of the product buttons above.

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