On Center Home | MyOnCenter Portal | Start an On-Screen Takeoff Trial | Request a Quick Bid Demo | Contact Us | SALES: 1-866-627-6246
   
 
Learn more about Searching
Looking for help for one of ConstructConnect's Other products? Login


Tools
Table of Contents

CLS - Trouble Opening Databases

Views: 2276 Last Updated: 02/14/2023 09:44 am 0 Rating/ Voters
Be sure to rate this article 5 Stars if you find it helpful!

Symptom

When opening a database you receive an error that the database is currently unavailable.

Cause

System resources can limit the number of databases On-Screen Takeoff® and Quick Bid can have open at the same time. All open databases appear on the Bids Tab in On-Screen Takeoff and in the Bid Navigator in Quick Bid.

Resolution

To resolve this issue, click File > Open and uncheck some of the open databases in the Open Databases window. This should free up system resources and allow you to open other databases.

Note
If you continue to receive this error, the database may be damaged. Please perform a Compact and  Repair using Microsoft's Access program and then try to re-open the database.

Symptom

When attempting to open a database, you may receive the following error message from the application:

The database is no longer available. Please check with your database administrator regarding this problem.

If you attempt to open the database in Microsoft Access, you will receive this error message:

Unrecognized database format...

Cause

This indicates that the database is no longer usable. This is normally caused by an immediate (even temporary) disconnection between the user and the resource (drive) where the database is stored and or a power interruption (causing the same disconnect).

For example, if a user has a network database open in an On Center Software application and his or her connection to the network is lost, the database is left in an unusable and, usually, un-correctable state. This can also happen with a local database if the machine immediately loses power (like a power failure or the cord being unplugged).

Resolution

The only way to recover from this is to restore the database from a previous backup - you will lose all work performed since that backup was created. See Related Articles for information on backing up and restoring databases.

Symptom

When opening a database, you receive an error stating that the database needs to be repaired, or is no longer a valid database file.

Selecting to repair the database results in the following error:

Windows cannot find C:\Program Files\Common Files\On Center Software\Server\JetComp.exe.

Cause

When communication with a database is immediately terminated, due to a power outage or a lost network connection, or an unexpected application termination, the database may become inaccessible. JetComp.exe can be utilized to repair the database and resolve this issue.

Resolution

To resolve this issue, perform the following steps.

Download the following file based on your Operating System type:

Once downloaded, double-click the EXE file and click Unzip to automatically copy JetComp.exe to the correct directory.

Once extracted, attempt to open the database again - the database should be automatically repaired without prompting.

Additional information on JetComp.exe is available in the Summary section of the following Microsoft Support Article: Article ID: 295334 - http://support.microsoft.com/kb/295334.

This only affects Microsoft Access-type databases.

Note
Be sure you are providing adequate backups of your database(s). See Related Articles for information on backing up Access-style databases.


Product documentation (user guides) describes functionality in the latest version of each major release and may not match the functionality in the version you are using. Please check the Product Information and Downloads pages by clicking one of the product buttons above.

Something Wrong with this Article? Let us Know! Copyright 2023 - On Center Software, Inc. by ConstructConnect - All Rights Reserved.